What is server requirement for codeigniter 4

Deepak Tailor Image
Deepak Tailor - Sep 15 2020
What is server requirement for codeigniter  4

PHP version 7.2 or newer is required for working on codeigniter 4, with the “intl” extension and “mbstring” extension installed in local server.

Some PHP extensions should be enabled on your server: php-json, php-mysqlnd, php-xml

In order to use the CURLRequest, you will need "libcurl" installed.

A database is required for most web application programming. Currently supported databases are:

1. MySQL (5.1+) via the MySQLi driver

2. PostgreSQL via the Postgre driver

3. SQLite3 via the SQLite3 driver

Not all of the drivers have been converted/rewritten for CodeIgniter4. The list below shows the outstanding ones.

1. MySQL (5.1+) via the pdo driver

2. Oracle via the oci8 and pdo drivers

3. PostgreSQL via the pdo driver

4. MS SQL via the mssql, sqlsrv (version 2005 and above only) and pdo drivers

5. SQLite via the sqlite (version 2) and pdo drivers

6. CUBRID via the cubrid and pdo drivers

7. Interbase/Firebird via the ibase and pdo drivers

8. ODBC via the odbc and pdo drivers (you should know that ODBC is actually an abstraction layer)

Note : you can used xampp or wamp servers but xampp server version above 2015 and greater and supported php 7.2 and above.

Deepak Tailor Image
Deepak Tailor

My name is Deepak tailor as a fullstack developer. I have been in the IT industry for the last 5 years. For professional and customize web development, you can send inquiry on our email.
----
You can contact him at support@fulstackdev.com